Welcome to Club Bennington

An official club forum for Bennington boats

Login Register

2018 20 sl Wiring / switches

Discussion in 'Owners Chat: Options and Upgrades' started by Ed Cook, Jan 1, 2019.

  1. Ed Cook

    Ed Cook New Member

    Messages:
    3
    Likes Received:
    0
    added led under deck lights to my 20sl and I have a livewell and accessories switch that turns on nothing but are wired to the wiring harnesses. Does anyone know what accessory goes to these switches
    Thanks
     
  2. cwag911

    cwag911 Moderator

    Messages:
    5,960
    Likes Received:
    2,034
    Location:
    Denver, NC on beautiful Lake Norman
    Sometimes you have extra switches if you don't have what they're used for.
     
  3. Mike D

    Mike D Member

    Messages:
    16
    Likes Received:
    2
    I have the same extra switch's and yes, they went no where. I used one of mine for the LED lighting too, but cant tell if there is an inline fuse or not (waiting for a fuse holder to come in the mail and will add it. I ended up adding some 12v led lights to the cup holders in the helm with an RF remote. Remote has a circular spin wheel to go through whatever color I want. I also added LED light rings behind the speakers so now I have LED behind the speakers and inside the cup holders. MUCH cheaper than having the boat built with it.

    Anyone run new wiring under their deck? I ran some wiring but couldn't get it inside a plastic housing like factory. Is it going to just deteriorate fast and be useless, or will it be ok? TO me, the black housing the factory uses looks like a cosmetic housing and not a protector from the elements. Thoughts?
     
  4. cwag911

    cwag911 Moderator

    Messages:
    5,960
    Likes Received:
    2,034
    Location:
    Denver, NC on beautiful Lake Norman
    There aren't inline fuses, there are circuit breakers by the switches. Your wiring will be fine without the black conduit.
     
  5. Mike D

    Mike D Member

    Messages:
    16
    Likes Received:
    2
    my oh my....i think ive been doing to many tweaks to the boat. i totally forgot that the switches have them built in. I had to redo the GPS inline fuse and then that was stuck in my mind that all +12v lines would have it....my bad. thank you for clearing.

    Forgot to mention, I'm on salt water...wiring is still good without conduit?
     
    cwag911 likes this.

Share This Page