Welcome to Club Bennington

An official club forum for Bennington boats

Login Register

Dual Battery Switch

Discussion in 'Technical Stuff' started by Brah, Dec 13, 2018.

  1. Brah

    Brah New Member

    Messages:
    1
    Likes Received:
    0
    I have a 2018 25SSRCXP Benny with a Yammy 200 with the dual battery switch. When I turn it to 1, nothing- won't start or work any electronics. When it's on both or 2, everything works. If I cut it to 1 while everything works, it cuts everything off. Batteries tested fine. Any ideas? I hope this is a fluke and not the norm as this boat only has 22 hours on it and is dry stored. I'm sure it's under warranty but looking to see if it's a "simple" fix before dragging it to the dealer. Thank you!
     
  2. Chris A

    Chris A Well-Known Member

    Messages:
    56
    Likes Received:
    150
    Location:
    Lake Murray, SC
    Check the cables of the #1 battery at the battery and at the switch...sounds like a loose cable.
     
  3. Havasu

    Havasu Well-Known Member

    Messages:
    699
    Likes Received:
    566
    Location:
    Fallbrook, California
    Yep, that's the first thing I'd check. Double check the ground(s) as well. Probably just something loose.
     
  4. BulldogsCadillac

    BulldogsCadillac Just some guy

    Messages:
    4,021
    Likes Received:
    1,454
    Location:
    Dauphin, Manitoba
    Also check the fuse on the distribution panel by the switch, if you have a multimeter you can double check the #1 battery voltage too.
     
    Michiman likes this.

Share This Page