Welcome to Club Bennington

An official club forum for Bennington boats

Login Register

Looking for help related to a Garmin 95

Discussion in 'Pontoon Forum' started by Fishing Barge, Nov 8, 2017.

  1. Fishing Barge

    Fishing Barge New Member

    Messages:
    2
    Likes Received:
    0
    Posting for a friend who hates computers. He has a Garmin 95 installed in his dash that is acting up. It keeps going to simulation mode on its own. Who has replaced this unit and knows what will fit the dash opening? Running wires for the transducer should not be a problem with it on the trailer. I saw in another post that someone had one that they had kept after upgrading their sonar. I am sure he would like to buy a used working unit and just swap his out. His pontoon is on Rough River Lake in Kentucky and I fish with him a lot and we did not know how much we relied on the thing until it screwed up! Any help would be appreciated. Thanks
     
  2. lakeliving

    lakeliving Well-Known Member

    Messages:
    6,514
    Likes Received:
    2,819
    Location:
    Howell, Michigan
    You could always direct message that member and ask if they have it. This site does not allow selling so you won't find a classifieds section. I have the Echo 100 in my boat and I think it is the same size as the 95. A quick call to garmin would verify that. Worth a shot as I bet it uses the same transducer.
     
  3. SEMPERFI8387

    SEMPERFI8387 Moderator

    Messages:
    7,853
    Likes Received:
    2,173
    Location:
    York, Pa
    I have one. PM me your address and I’ll ship it Saturday. Let me know if you need the transducer also. Worked fine when I removed it.
     
  4. SEMPERFI8387

    SEMPERFI8387 Moderator

    Messages:
    7,853
    Likes Received:
    2,173
    Location:
    York, Pa
    Also, a 53DV fits with just a slight 1/8” or so trim to, I believe the top edge. That’s what I went to on that boat.
     
  5. Michiman

    Michiman Well-Known Member

    Messages:
    1,175
    Likes Received:
    502
    Location:
    Okemos, MI
    It sounds to me like it might be a wiring problem with the power getting shut off when the boat is not in use, thereby placing it into the "demo" mode the next time. Just a thought...
     

Share This Page