Smartcraft guages

shixon

Active Member
Messages
38
Reaction score
3
Location
Blue Ridge, GA
Hi everyone. Just bought a new Q25 two weeks ago that the local dealer had in inventory. I have one question though -- I seem to have gotten the Garmin GPS to talk to the speedometer as I can see heading and speed in the digital readout, but the speed needle doesn't seem to register the current speed. Have I missed something or does the needle not display the speed from the GPS?

Thanks for the help
 

putz21

Well-Known Member
Messages
48
Reaction score
1
Location
Tomahawk, WI
Hi everyone. Just bought a new Q25 two weeks ago that the local dealer had in inventory. I have one question though -- I seem to have gotten the Garmin GPS to talk to the speedometer as I can see heading and speed in the digital readout, but the speed needle doesn't seem to register the current speed. Have I missed something or does the needle not display the speed from the GPS?

Thanks for the help
Is the speed needle moving at all? Or are you saying it dosn't match the digital readout?
 

shixon

Active Member
Messages
38
Reaction score
3
Location
Blue Ridge, GA
Is the speed needle moving at all? Or are you saying it dosn't match the digital readout?
It doesn't move at all.
 

cwag911

Moderator
Messages
5,993
Reaction score
2,125
Location
Denver, NC on beautiful Lake Norman
Someone else had the same problem on here and it turned out that the speedo was wired wrong. The dealer corrected the problem.
 

bthrel

Well-Known Member
Messages
52
Reaction score
11
Location
Cuba Landing, TN
Someone else had the same problem on here and it turned out that the speedo was wired wrong. The dealer corrected the problem.
Yes, that was me, on a 24 SSLX, turns out the blue and black wire in the deutsch connector from the main wiring harness to the speedometer were reversed. Symptoms were no readout in the LCD display for heading and no needle movement. Once the wires were swapped everything worked fine.

Brian
 

Okie Dave

Well-Known Member
Messages
87
Reaction score
17
Is your Q an I/O or outboard? Mine has the I/O engine and the Garmin GPS.The heading and digtial speed work fine but the needle does not move. Was told by dealer that the pitot tubing was not installed at the factory from the outdrive to the gauge. They have the parts in from Bennington to fix next time I bring the boat in for service. This could be what your problem is as well.
 

shixon

Active Member
Messages
38
Reaction score
3
Location
Blue Ridge, GA
Is your Q an I/O or outboard? Mine has the I/O engine and the Garmin GPS.The heading and digtial speed work fine but the needle does not move. Was told by dealer that the pitot tubing was not installed at the factory from the outdrive to the gauge. They have the parts in from Bennington to fix next time I bring the boat in for service. This could be what your problem is as well.
That is exactly the same issue I'm having digital speedo and heading are fine, but no needle movement. I'll ask the dealer next time I'm at the lake. I would have thought the the gps would have overridden the pitot readings though?
 
Top