kicker amp problems

Miken

Member
Messages
11
Reaction score
11
A novice audio guy here and I need help!!!. I have had a problem with kicker amp for 2 seasons. Last year swapped out the amp. This year's service included swaping out the head unit. Worked great for one outting then started the same issue....... The amp cuts on and off repeatedly and at with no consistent pattern. Will sometimes play for 5 or 10 minutes before starting. Any suggestions would be appreciated. I know I can take it back to the dealer for service but I don't think they are great audio support (they swapped out the amp and the head unit), AND I don't have a trailor so that creates a major headache I want to avoid.
 

Potomacbassin’

Well-Known Member
Messages
148
Reaction score
151
Location
Annandale, VA
Sounds like a voltage issue or loose connection. My old Eagle Talon started sputtering inconsistently on long drives. Swapped out plugs, wires and coil pack before finding the loose positive clamp on the battery. Every time I hit a bump/pothole the connection would break and the car would violently stall. See if your issues are related to movement in the boat.
 

Paint Man

Active Member
Messages
35
Reaction score
7
Location
Omaha Nebraska
A novice audio guy here and I need help!!!. I have had a problem with kicker amp for 2 seasons. Last year swapped out the amp. This year's service included swaping out the head unit. Worked great for one outting then started the same issue....... The amp cuts on and off repeatedly and at with no consistent pattern. Will sometimes play for 5 or 10 minutes before starting. Any suggestions would be appreciated. I know I can take it back to the dealer for service but I don't think they are great audio support (they swapped out the amp and the head unit), AND I don't have a trailor so that creates a major headache I want to avoid.
I’m having the exact problem with my 2019 R. Amp cycles on and off, I can’t seem to fix the problem. I have not replaced amp or head unit yet, my issue just started this week.
 

Ishoot308

Active Member
Messages
39
Reaction score
24
Make sure nothing is leaking on to your amp from above. I had the same issue and found excessive water was getting in the amp making it cut out. These amps have a cutout circuit when moisture gets too high to avoid damage. It could be rain water from a previous day that dripped down on your amp.

In my instance, my windshield had one loose unsealed screw that allowed water to get in the helm storage area where amp is located and drip directly on the amp. I sealed and tightened the screw and that fixed the problem.

Good Luck!

Dan
 

basshawk84

Well-Known Member
Messages
144
Reaction score
128
Location
East Texas
Does it only do it at a loud volume? Could be over temp or maybe the power wires feeding it are too small to carry the current?
 
Top