Sea star assist help

MattF

New Member
Messages
4
Reaction score
3
My 2018 SX25 with Yamaha vmax 250 had power steering stop working. I was told 3 possible causes. 1. Battery low but batteries are like new and not used much 2. Fuse out- if so where is such fuse to replace 3. Air in hydraulic line in which case lines need to be bled and new fluid put in. Any advice is appreciated
 

jhill

Well-Known Member
Messages
237
Reaction score
301
Location
Portland, Oregon
I think I would start with using a multimeter at electric assist pump wiring connections (make sure key on) and see if it reads 12vdc or 0 and work backwards to where ever wiring goes looking for fuses, etc. You can buy cheap meter at Harbor Freight if don't have one. Maybe verify battery cables have good connection with no corrosion. Maybe look around batteries for a fuse.
 

lakeliving

Well-Known Member
Messages
8,139
Reaction score
6,126
Location
Michigander living In Palm City FL
Good news is it is under warranty. I'd make sure the purple wire under the helm is getting power. I'm guessing it is not.
 

MattF

New Member
Messages
4
Reaction score
3
Thanks for info folks. I do appreciate it. Shops are booked for 2 weeks here so I’d like to solve on my own if it’s something as easy as a fuse or low battery. Going down in the morning to see what I can find. Much appreciated.
 

MattF

New Member
Messages
4
Reaction score
3
Turns out battery, fuse and fluid all good. Bennington tech on phone helped me check each spot. Pump is bad and will be replaced under warranty. Good news I can still get around for a few more weeks. Thanks for information.
 

Magician

Active Member
Messages
26
Reaction score
15
What checks did the tech advise you to do? Similar issue with my boat.
 

MattF

New Member
Messages
4
Reaction score
3
What checks did the tech advise you to do? Similar issue with my boat.
1st check battery power, 2nd check power assist pump to see if green light is on, 3rd check fuse (mine was purple wire), 4th with power on is power assist pump making a humming noise when steering wheel is turned back and forth (mine was not) 5th if steering is working but rough and inconsistent there may be air in line in which case they need to bleed lines. Bottom line my pump is getting power and I have plenty of fluid so pump must be bad. Hope this helps.
 

Magician

Active Member
Messages
26
Reaction score
15
Yeah Ive added fluid and I have power but mine is still rough and hard to turn left on plane. It’s easy to turn at idle but has never been 1 or 2 finger easy. Sounds like I have a few more things to check but with it still under warranty I’m making a list for when the season is over.

Thanks for getting back to me.
Good luck
 
Top